Mina Testnet Phase 4 – Staking Signups

Solution from discord - https://discord.com/channels/484437221055922177/583400552487059546/746746082498969681

sudo apt update && sudo apt install docker.io -y

Then run this command

docker run --interactive --rm --volume $(pwd)/keys:/keys codaprotocol/coda-genkey:latest -privkey-path /keys/mywallet
1 Like

It works. Just did it in a clean WSL install on 20.04

Ubuntu 18 everything generated fine, it didn’t work on Ubuntu 20

i run with mac centos,and when i execute command

coda-generate-keypair-phase3 -privkey-path keys/my-wallet

error fllow

dyld: Library not loaded: /usr/local/opt/libffi/lib/libffi.7.dylib

finnally solution with

cp libffi.6.dylib libffi.7.dylib

is right way? Excuse me?

Hi all i’ve created video how to created public key easily here & don’t forget to send it in to the form, ty;

2 Likes

On Ubuntu 20.04
wget http://archive.ubuntu.com/ubuntu/pool/main/p/procps/libprocps6_3.3.12-3ubuntu1_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/libf/libffi/libffi6_3.2.1-8_amd64.deb
dpkg --install lib*.deb

Solved my problem, good luck

1 Like

and if happend Depends: libjemalloc1 but it is not installable
wget http://repo.percona.com/apt/pool/main/j/jemalloc/libjemalloc1_3.6.0-2.focal_amd64.deb
dpkg --install lib*.deb

1 Like

Hi Mirror how are you :wave:? Thx for your contribution :pray: